[Date Prev][Date Next][Thread Prev][][Date Index][Thread Index]

Re: emacs-w3m can't send post data to the form which has a form with 'enctype=multipart/form'.


We're sorry for a late response.  Persons who are familiar with
forms seem to be busy now.  Though I'm not well informed to
forms, I seem to have solved the problem.  Please try the CVS

>>>>> In [emacs-w3m : No.08453] JongKyu Baek wrote:

> When I tried to search at htpp://emacswiki.org/ with 'emms' string, I
> expected a search result page.  But emacs-w3m spit out below
> messages.


> Then I tested some examples.  I found out that it happened at
> following form with 'enctype="multipart/form-data"'.  Below is html
> source of search form at http://emacswiki.org/.

> -- start of the form.
> <form method="get" action="http://www.emacswiki.org/cgi-bin/wiki";
> enctype="multipart/form-data" class="search">


Emacswiki specifies the "get" method for "multipart/form-data",
however RFC2070 recommends to use the "post" method as follows:

5.2. Form submission
   The best solution is to use the "multipart/form-data" media type
   described in [RFC1867] with the POST method of form submission.

And the cause of the problem is that emacs-w3m cannot send such
data using the "get" method.  I've modified w3m-form.el so as to
use the "post" method in such a case.