[Date Prev][Date Next][Thread Prev][][Date Index][Thread Index]

[SOLVED] Trouble starting w3m

On 2017-06-08 03:21, Boruch Baum wrote:
> 1] M-x w3m produces an error message:
>    if: Symbol's value as variable is void: w3m-filter-configuration

I don't understand why this was happening but I can explain
what solved this issue. I had a number of personal filter
functions defined in my emacs-w3m-init file (none of which
referred to w3m-filter-configuration). When I moved those
defun statements into and (eval-after-load 'w3m-filter ..)
statement, the error message stopped appearing.

> 2] w3m-mode-hook seems to be set to something quite unusual. The Help
> message for the variable reads:
> w3m-mode-hook is a variable defined in `w3m.el'.
> Its value is (w3m-lnum-mode my-w3m-mode-hook bookmark-w3m-prepare
>    #[nil "\301\302\303#\210\301\304\303#\207"
>     [w3m-mode-map define-key "\367" org-w3m-copy-for-org-mode ""]
>     4])

Well, I guess I'm the last one on this list to learn that
org-w3m-copy-for-org-mode is a function that seems to have
been originally submitted to the emacswiki and eventually
made its way into either the org-mode package or into
debian's version of emacs / org-mode. It allows an html
fragment to be copied into org-mode while retaining any url
link information embedded in the selection. For me, it
appears in binary file /usr/share/emacs/24.5/lisp/org/org-w3m.elc.

So this seems to be an issue outside of the emacs-w3m package.

CA45 09B5 5351 7C11 A9D1  7286 0036 9E45 1595 8BC0