[Date Prev][Date Next][Thread Prev][][Date Index][Thread Index]

Re: w3m on NT Emacs


I forward your message posted to the gnu.emacs.help newsgroup
(or possibly help-gnu-emacs <at> gnu.org?) to the emacs-w3m

>>>>> In <mailman.816.1093945568.1998.help-gnu-emacs@gnu.org>
>>>>>	Gustaf Erikson wrote:

> I'm using NT Emacs ("GNU Emacs 21.3.1 (i386-msvc-nt5.1.2600) of
> 2003-03-28 on buffy") on Windows XP. I would like to use w3m to format
> the inevitable HTML mail from my employer. This has worked before, but
> since getting a new computer it doesn't work.

> I had my old .emacs and .gnus files, but after messing around with
> them I removed all references to w3m vars and functions and started
> over.

> I d/l and installed emacs-w3m v. 1.4.3. I couldn't compile the latest
> version of w3m under cygwin, but I had an older version (v. 0.4.1)
> available, and this works flawlessly under cygwin bash. Also, if I
> start emacs from bash inside the console, M-x w3m works fine and I can
> browse.

I'm not familiar with cygwin, so I won't be able to help you
about w3m unfortunately.

> But when I try to do the same thing in "normal" windows mode, I just
> get a blank buffer. I see the w3m menubar and the tabs, but no
> output. When entering remote URL, ir just says

> "Request sent, waiting for response...done".

> Any ideas of what might cause this? Is it a question of w3m's output
> being redirected somewhere else?

Does emacs-w3m work with local html contents?  To check it,
type `M-x w3m-history RET', visit the `about:' page or visit a
url which begins with `file:'.

We got a message about a similar problem from a Gentoo Linux
user last week and it has been solved.  Then I added the
following part to the FAQ list.

   * Q. Why I cannot visit web pages using emacs-w3m?  There is no
     problem when visiting local html files or using w3m barefoot,

     What is called the asynch patch(1) is applied to the w3m command
     which some Linux distribution (e.g. Gentoo Linux) contains.  It is
     useful when using w3m barefoot, however it might make emacs-w3m
     hang.  If it is suspected, we recommend you reinstall the w3m
     command from the original source.

   (1) w3m on cygwin (http://www.page.sannet.ne.jp/knabe/w3m/w3m.html)

Should I add cygwin to the section?  ;-)