[Date Prev][Date Next][Thread Prev][][Date Index][Thread Index]

Re: html images still not viewed in gnus

First of all, I storongly recommend you make it possible to read
the Info manual.  I think you might be able to find a solution
by yourself.

(We are very busy answering to too basic questions even though
we only have the same time that you have.  Although any
questions are welcome, you should read the manuals, including
the Emacs manual, and do all you can in advance.)

Make sure things listed below are what they should be.

* In the /usr/local/info/ directory, there are files of which
  names begin with `emacs-w3m' (e.g., emacs-w3m.info,
  emacs-w3m.info-1, ...).  If not, try to install emacs-w3m
  again, and confirm where those files are installed.  The
  directory can be altered using the `--infodir=' configure

* In the /usr/local/info/dir file, there is the entry which
  begins with `* Emacs-w3m:'.  If not, add it to the file like
  the following:

  % su root
  # echo '* Emacs-w3m: (emacs-w3m). An Emacs interface to w3m' >> /usr/local/info/dir

* Start Emacs and make sure the `Info-default-directory-list'
  Lisp variable contains the dirctory named `/usr/local/info/'
  (it might be `/usr/local/info').  To know the value for the
  variable, type `C-h v' (or `M-x describe-variable RET') for
  it.  If not, put the following lines in your ~/.emacs file.

(setq Info-default-directory-list
      (cons "/usr/local/info/" Info-default-directory-list))
(eval-after-load "info"
  '(setq Info-directory-list Info-default-directory-list))

And then, start Emacs and type `M-x info RET d m Emacs-w3m RET'.
To learn how to use Info, type `M-x info RET d m info RET'.

>>>>> In [emacs-w3m : No.07752] Rodolfo Medina wrote:

> Thanks indeed for your help.
> The matter seems harder than I thought.
> I repeated the installation of emacs-w3m into another linux partition
> where I have Emacs CVS 21.3.50 installed one month ago,
> which includes gnus 5.11 (it should support emacs-w3m, shouldn't it?),

Yes it does.

> but encountered the same problems.
> Before installing emacs-w3m, I installed the following packages:
> gc.tar.gz; openssl-0.9.7e.tar.gz; w3m-0.5.1.tar.gz.
> I don't know if it's important, but during the 'make' step
> in the installation of openssl-0.9.7e.tar.gz
> the following message went on appearing:

> `-mcpu=' is deprecated. Use `-mtune=' or '-march=' instead.

> No other problems seemed to occur.
> I'm sending the html mail in question to your personal address,
> from MS Outlook. It's just one the many adverts you get from internet.

Unfortunately, it has not yet reached to me.  I don't know why,
but it might be better to compress it using gzip, zip, lha, etc.

> How do I run emacs-w3m? If I do '$ emacs-w3m' from command line,
> it says: bash: emacs-w3m: command not found. If, within Emacs, I do
> `M-x emacs-w3m RET', in the echo area it says: [No match].
> As well, if within Emacs I do `M-x report-emacs-w3m-bug RET',
> in the echo area it says: [No match].
> Within Emacs, I did 'M-x w3m RET', then 'M-x report-emacs-w3m-bug RET'
> and in the echo area appeared the prompt:
> Bug subject:
> .

Sorry.  The report-emacs-w3m-bug command is not autoloaded since
emacs-w3m should be run beforehand to gather some infomations.

> I replied with: 'emacs-w3m-version RET', and a message appeared,
> which contained the following:

> System Info to help track down your bug:
> ---------------------------------------
> emacs-w3m-version
>  => "1.4.3"
> emacs-version
>  => "GNU Emacs (i686-pc-linux-gnu, X toolkit)\n of 2005-01-22 on
> localhost"
> mule-version
>  => "5.0 (SAKAKI)"
> system-type
>  => gnu/linux
> w3m-version
>  => "w3m/0.5.1"
> w3m-type
>  => w3m-m17n
> w3m-compile-options
>  => ("lang=en" "m17n" "image" "color" "ansi-color" "mouse" "gpm" "menu"
> "cookie" "ssl" "ssl-verify" "external-uri-loader" "w3mmailer" "nntp" "ipv6"
> "alarm" "mark")
> w3m-language
>  => nil
> w3m-command-arguments
>  => nil
> w3m-command-arguments-alist
>  => nil
> w3m-command-environment
>  => nil
> w3m-input-coding-system
>  => utf-8
> w3m-output-coding-system
>  => utf-8
> w3m-use-mule-ucs
>  => nil

Thanks.  There seems to be no oddity.

> Katsumi:

>> [...]
>> or to evaluate[1] the following S-expressions:
>> emacs-w3m-version
>> (locate-library "w3m")
>> [1] Copy each S-expression into the *scratch* buffer and type
>> `C-j' at the end of the line.

> I copied the two expressions into the *scratch* buffer and did `C-j'.
> For the first one I got this error message:

> Debugger entered--Lisp error: (void-variable emacs-w3m-version)
>   eval(emacs-w3m-version)
>   eval-last-sexp-1(t)
>   eval-last-sexp(t)
>   eval-print-last-sexp()
>   call-interactively(eval-print-last-sexp)

You needed to load w3m or to run w3m (in this situation, `w3m'
means the w3m Lisp command which is provided by the emacs-w3m

> ; when I evaluated the second, in the line below appeared the following:

> "/usr/local/share/emacs/site-lisp/w3m/w3m.elc"

That's good.  The directory is very common.

>> By the way, before installing emacs-w3m, you can see what
>> modules will be installed to where.  To do that, type the
>> following after you ran the configure program.
>> make what-where

> I did so, and this was the output:

> ----------------------------------------------------------------------
> [rodolfo@localhost emacs-w3m-1.4.3]$ make what-where

> lispdir=/usr/local/share/emacs/site-lisp/w3m
> ICONDIR=/usr/local/share/emacs/21.3.50/etc/w3m/icons
> infodir=/usr/local/info

> install:
>   *.el, *.elc, ChangeLog* -> /usr/local/share/emacs/site-lisp/w3m/
>   *.info, *.info-*        -> /usr/local/info/

> install-icons:
>   *.xpm                   -> /usr/local/share/emacs/21.3.50/etc/w3m/icons/

> install-info:
>   *.info, *.info-*        -> /usr/local/info/
> ----------------------------------------------------------------------------
> ------

That's good.

> In my .emacs there is:

> (require 'w3m-load)

> , and in my .gnus.el there is:

> (setq mm-inline-text-html-renderer 'w3m)

`mm-inline-text-html-renderer' is semi-obsolete.
Use of `mm-text-html-renderer' is better.  It is mentioned in
the documentation for the `mm-inline-text-html-renderer'
variable; use `C-h v' (or `M-x describe-variable RET') for it.

> (setq mm-inline-text-html-with-images t)
> (setq mm-w3m-safe-url-regexp nil)

Please read the Info manual by typing:

M-x info RET d m Emacs-w3m RET m Gnus RET C-s Notes

> I'm also attaching all the steps I followed during the installation of
> emacs-w3m.

Hm, I couldn't find out what blocks you to see inline images
after all.