[Date Prev][Date Next][Thread Prev][][Date Index][Thread Index]

Re: Once more emacs-w3m and w3mmee

>>>>> In [emacs-w3m : No.07892] Elias Oltmanns wrote:

> Hi all,

> sorry for bothering you once more with this topic apparently returning
> regularly. I'd really like to get emacs-w3m working with w3mmee. The
> problem I have is that emacs-w3m shows a question mark for each non
> ASCII character as if emacs couldn't handle the characterset. w3mmee
> run from the console though doesn't have these difficulties at all. My setup
> is the following:
> - Debian/Sarge with utf-8 locale (de_DE.UTF-8);
> - w3mmee: w3m/0.3.2+mee-p24-19+moe-1.5.0;
> - emacs: GNU Emacs 21.3.1;
> - emacs-w3m: cvs branch updated this morning.

I normally use w3m but I have w3m/0.3.2+mee-p24-21+moe-1.5.8
installed and can test it with Emacs 21.3 and Mule-UCS.  I'm
almost ignorant for w3mmee, though.

> ---- ~/.w3mmee/config ----
> tty_charset utf-8
> ;mylang_charset ISO-8859-1
> mylang de,en
> mylang_charset ISO-8859-1
> ---- ~/.w3mmee/config ----

I tried it and saw almost all non-ASCII characters were shown as
question marks.  I think it is useless.  Instead, I tried the
following and got a good result.

cp /usr/local/etc/w3mmee/w3mconfig.utf-8 ‾/.w3mmee/config

Both `w3m-input-coding-system' and `w3m-output-coding-system'
were `ctext' which is the default then.  Furthermore, I
confirmed setting one or both to `utf-8' causes no problem.

> ---- ~/.emacs ----
> ...
> (setq locale-coding-system 'utf-8)
> (set-terminal-coding-system 'utf-8)
> (set-keyboard-coding-system 'utf-8)
> (set-selection-coding-system 'utf-8)
> (require 'w3m-load)
> (setq w3m-command "/usr/bin/w3mmee")
> ;(setq w3m-output-coding-system 'utf-8)
> (setq w3m-coding-system-priority-list '(iso-8859-1 utf-8))
> ...
> ---- ~/.emacs ----

> The lines indicated with a preceding ; have been activated in
> different combinations to test there effect. What strikes me most is
> the effect of setting w3m-output-coding-system to 'utf-8. If I do
> that, two instead of one question marks appear for each non ASCII
> character. Thus it seems more sensible to leave this option alone
> (strange), which means that it is set to ctext.

Although I'm not well informed of all of those, I know that
question marks being displayed means Emacs cannot recognize them
as valid characters.  On the other hand, that empty boxes are
displayed suggests lack of some fonts.

> Personally I'm not quite sure whether the w3mmee process started by
> emacs is actually running in utf-8 mode, that is to say, whether
> /etc/w3mmee/w3mconfig.utf-8 is parsed rather than one of the other
> config files.

> Have you any ideas how to track this problem down?

> Thank you very much in advance,

> Elias

Probably, a person who is more appropriate than I should answer
your question. ;-)