[Date Prev][Date Next][Thread Prev][][Date Index][Thread Index]

Re: w3m - ASCII 160

Hi Yamaoka san --

Katsumi Yamaoka wrote:
> >>>>> In [emacs-w3m : No.09103] Ron Isaacson wrote:
> > I use: XEmacs 21.4.12, Wanderlust 2.12.2, emacs-w3m 1.4.4, and w3m to
> > render html mails inside Wanderlust message buffers (all on Linux). I
> > used to use w3m 0.3.1, and just recently switched to 0.5.1.
> First of all, I might be unable to test it fully since I don't
> have such a very old version of XEmacs 21.4, sorry.
> (I recommend upgrading your XEmacs 21.4 and also the packages
> into the most recent ones, since the old XEmacs 21.4s have some
> serious bugs AKAIK).

I also tried 21.4.17, but it has the same problem. I recently tried
upgrading to 21.5, but couldn't get Wanderlust working there at all.
That's another issue though. :-)

> > Since switching, I notice that ASCII 160 (0xA0) in mails I receive is
> > rendered as a question-mark (?). I have:
> >   (standard-display-ascii 160 " " (selected-device))
> Without this, XEmacs 21.4.20, launched with the -vanilla option,
> displays a blank space for the string "\xA0".

When I used w3m 0.3.1, I didn't have this problem at all; w3m passed
the raw character back to xemacs, and it was drawn as expected. It may
only be in older versions that the display override was necessary, but
in any case, this problem seems to be either in w3m or in the
emacs-w3m options.

Do you know exactly what command line emacs-w3m sends to w3m, and how
it's affected by the encoding variables (w3m-output-coding-system,
etc.), so I can test this directly in w3m, outside of emacs?

> > but it seems this character is getting drawn as a question-mark by
> > w3m, and emacs is never seeing the raw character.
> > Does anybody know of differences between w3m 0.3.1 and 0.5.1 that
> > would cause this to change, or know how to get this properly drawn as
> > a blank space?
> Is the mail in question such as the following?

Yes, this gets drawn for me as:

  [2  <text/html; US-ASCII (quoted-printable)>]

If I switch this buffer to hexl-mode, I can see that emacs actually
sees this character as a question-mark (0x3f). So somewhere between
w3m and xemacs, the raw character is getting lost.

Ron Isaacson
Morgan Stanley
ron.isaacson@xxxxxxxxxxxxxxxxx / (212) 276-0268

NOTICE: If received in error, please destroy and notify sender.  Sender
does not waive confidentiality or privilege, and use is prohibited.