[Date Prev][Date Next][Thread Prev][][Date Index][Thread Index]

Re: Cannot open load file: cl

Hi Robert.

Now, CVS sources(as not eq. `release sources') are some additional
steps required.

In Terminal:
1.checkout sources from cvs repos : "cvs -d<path> co emacs-w3m"
2.run "autoconf" command. This commad to generate `configuire' script
file from `configure.in' file.
3.run "./configure" script file, then to generate `config.status' file.
4.run "make" and "make install".

Please try again. And if error occur or don't solve problem, please re-mail.


2007/5/5, Robert J. Chassell <bob@xxxxxxxxxxxxxxx>:
Dear Bug Team!

From CVS, on Sat, 2007 May 5 13:55 UTC, I updated Emacs W3M with no
trouble, by evaluating

     (cd "/usr/local/src/emacs-w3m/")
     (cvs-update "/usr/local/src/emacs-w3m/" '("-dP")))

However, when I evaluated this expression

       (cd "/usr/local/src/emacs-w3m/")
       (compile "time make -k lisp"))

This message appeared in the *compilation* buffer:

    Cannot open load file: cl
    configure: error: Process couldn't proceed.  See the above messages.

so I am using a much older version of emacs-w3m.

The reason for the attempt is that with this morning's CVS snapshot of
GNU Emacs, W3M mode did not offer a default buffer when I ran C-x b
(w3m-e21-switch-to-buffer).  (That was before I ran the update.  The
update removed w3m-e21.el and changed w3m-e21-switch-to-buffer to
w3m-switch-to-buffer, which makes sense.  However, I do not understand
why I cannot build.)

What should I do?