[Date Prev][Date Next][Thread Prev][][Date Index][Thread Index]

Re: buttons in forms don't work anymore for XEmacs

Katsumi Yamaoka <yamaoka@xxxxxxx> さんは書きました:

>>>>>> In [emacs-w3m : No.09539] Mike wrote:
>> With current CVS HEAD (checkout from today), I cannot use
>> buttons in forms with XEmacs.
>> For example, when going to the URL
>>     http://www.google.com
>> entering a word to search for moving the cursor on to
>> the [Google search] button and pressing RET just gives
>> the error message:
>>     No URL at point
>> This worked with emacs-w3m 1.4.3 but seems to be broken
>> since emacs-w3m 1.4.4.
> What a long-standing bug it's been.  Moreover, the version for
> Emacs has the same bug which arises if w3m-form-use-fancy-faces
> is nil.  I've fixed it in the CVS trunk.  Thank you for bringing
> it up.

Thank you very much, it works fine now.

>> 睡眠不足はいい仕事の敵だ。
> Indeed.
>> I � Unicode
> What does `�' stand for? ;-)

U+FFFD (REPLACEMENT CHARACTER). Some time ago a colleague
had a T-shirt where the ❤ in “I ❤ Unicode”
had been replaced by a box. I.e. a T-shirts like one of these:


U+FFFD is used when something didn't work right, therefore
I thought I could put that joke into my signature
by using U+FFFD. But apparently nobody understands that ☹.

Mike FABIAN   <mfabian@xxxxxxx>   http://www.suse.de/~mfabian
I � Unicode