[Date Prev][Date Next][Thread Prev][][Date Index][Thread Index]

Re: w3m-session and emacs23

>>>>> In [emacs-w3m : No.10717] Francis Moreau wrote:
>> What command did you perform when you thought w3m-session didn't
>> work?

> M-s

>>  Did it issue a warning or an error message then?

> yes:
>         mapc: Wrong type argument: listp, w3m-session

It seems that arguments passed to `mapc' contain the symbol
`w3m-session', however I don't see the code that uses such one.
Could you try debugging to get the Lisp backtrace?  To do that,
load the w3m-session.el file (not the w3m-session.elc file) by
`M-x load-file RET', perform `M-x toggle-debug-on-error RET',
type `M-s', and then,  send the contents of the "*Backtrace*"
buffer to the list.  It will help us to investigate the problem.

> also it looks like the jao-w3m-go-to-linknum() function (please see below
> my ~/.emacs file) doesn't work anymore, I got this message now

>        jao-w3m-go-to-linknum: Symbol's value as variable is void:
> w3m-link-numbering-mode

`jao-w3m-go-to-linknum' seems to need to load w3m-lnum.elc by
itself since the `w3m-link-numbering-mode' variable that is first
used in the function is not autoloaded.  For example:

(defun jao-w3m-go-to-linknum ()
  "Turn on link numbers and ask for one to go to."
  (require 'w3m-lnum)
  (let ((active w3m-link-numbering-mode))

Otherwise, simply add this line in your ~/.emacs-w3m.el file:

(require 'w3m-lnum)

>> What kind of a platform do you run emacs-w3m on?

> on Linux (fedora 9).

>>  Have you tried the most recent emacs-w3m?
>> That is: http://cvs.namazu.org/emacs-w3m.tar.gz

> Ok, I tried this one and did the ./configure; make; make install but it
> still fails to show me my sessions.

>> Emacs-w3m is always being developed, so you might have gotten
>> the one in which some bugs have not been fixed yet.

> I didn't know about that. The packages avalaible on the web site are
> pretty old almost 4 years old so I thought the development was
> stalled somehow. Good to hear I was wrong !

> Here's what I put in my .emacs to load w3m, maybe that can help:

> (if (= emacs-major-version 23)
>     (add-to-list 'load-path "/usr/local/share/emacs/site-lisp/w3m")
>   (add-to-list 'load-path "~/share/emacs/w3m/e22")
> )

> (require 'w3m-load)
> ;;(require 'w3m)
> ;;(require 'w3m-session)
> ;;(require 'w3m-lnum)

> (setq browse-url-browser-function 'w3m-browse-url)
> (setq browse-url-new-window-flag t)
> (setq w3m-use-cookies t)
> (setq w3m-key-binding 'info)
> (setq w3m-home-page "http://www.google.fr";)
> (setq w3m-use-cookies t)

> (defun jao-w3m-go-to-linknum ()
>   "Turn on link numbers and ask for one to go to."
>   (interactive)
>   (let ((active w3m-link-numbering-mode))
>     (when (not active) (w3m-link-numbering-mode))
>     (unwind-protect
> 	(w3m-move-numbered-anchor (read-number "Anchor number: "))
>       (when (not active) (w3m-link-numbering-mode)))))

> (defun local-w3m-mode-hook ()
>   (define-key w3m-mode-map "f" 'jao-w3m-go-to-linknum)
>   (define-key w3m-mode-map (kbd "C-x b") nil))

> (add-hook 'w3m-mode-hook 'local-w3m-mode-hook)

> (setq w3m-session-file "~/.emacs.d/w3m-session")
> (setq w3m-session-save-always nil)
> (setq w3m-session-load-always nil)
> (setq w3m-session-show-titles t)
> (setq w3m-session-duplicate-tabs 'ask)

Looks good, except for `jao-w3m-go-to-linknum'.

;; I will be absent in the net till Monday.  Sorry.