[Date Prev][Date Next][Thread Prev][][Date Index][Thread Index]

Chinese websites not rendered correctly

Dear Emacs/w3m Fans:

I have been having a lot of problems getting Emacs-w3m to display
Chinese websites correctly (both GB2312 and Big5). When I open these
same websites directly through w3mmee (the w3m variant I'm using),
they display correctly, but from Emacs it's all messed up.

Here is how w3m and emacs-w3m display baidu.com and google.tw,

  [1] http://www.boyechko.net/images/w3m/w3m-baidu.png
  [2] http://www.boyechko.net/images/w3m/emacs-w3m-baidu.png
  [3] http://www.boyechko.net/images/w3m/w3m-google_tw.png
  [4] http://www.boyechko.net/images/w3m/emacs-w3m-google_tw.png

I have tried changing w3m-coding-system as well as
w3m-input-coding-system and w3m-output-coding-system, but while the
display changes, it never actually displays the characters correctly.
This happens even if I run emacs with "emacs -Q" and only add
emacs-w3m directory to load-path and evaluate (require 'w3m-load). I
would appreciate any help you could provide.

System information:

Slackware 13.1 Linux
GNU Emacs 23.2.1 run in rxvt-unicode v9.07

w3m version w3mmee/0.25-cvs-343+moe-1.5.8, options lang=many,
kanji-symbols, color, mouse, menu, cookie, ssl, ssl-verify, w3mmailer,
mark, romaji

emacs-w3m from CVS (as of 2010-07-13); also tried v1.4.4


Richard Boyechko