[Date Prev][Date Next][Thread Prev][][Date Index][Thread Index]

Re: error in process sentinel: Empty string for buffer name is not allowed

On Tue, Aug 30, 2011 at 7:34 PM, Katsumi Yamaoka <yamaoka@xxxxxxx> wrote:
> In [emacs-w3m : No.11627] Billy wrote:
>> Hello.
>> I see a bug when accessing the following site using emacs-w3m:
>> http://duckduckgo.com/lite/ - this works, but:
>> https://duckduckgo.com/lite/ - prints the following error message:
>> error in process sentinel: generate-new-buffer: Empty string for
>> buffer name is not allowed
>> error in process sentinel: Empty string for buffer name is not allowed
>> https://duckduckgo.com/lite/?q=test - this works, but clicking 'Next
>> Page' prints the same error message.
>> Using Ubuntu 10.10:
>> emacs-w3m 1.4.394+0.20100524-1 (package w3m-el-snapshot)
>> emacs
>> Thank you.
> Thank you for the definite report but I was unable to reproduce
> an error for those two cases.  Maybe it's due to something that
> I've fixed after 1.4.394.  Could you try the most recent one?
> The latest version is 1.4.442:
> http://cvs.namazu.org/emacs-w3m.tar.gz

Upgraded to the cvs development version, but getting same error.
It happens when I click the 'next-page' widget for more results, not
on loading the page.
I've only been able to reproduce this bug on the SSL version of the
duckduckgo page. I don't get it using https://encrypted.google.com --
but that page renders the 'next results' as a regular link, not a
widget (if that makes a difference).

w3m -version (from Ubuntu repo):
w3m version w3m/0.5.2, options