[Date Prev][Date Next][Thread Prev][][Date Index][Thread Index]

Re: emacs-w3m doesn't create Makefile (using Windows 10 64-Bit with Cygwin64)

Hi John,

On Tue, 24 Nov 2015 13:15:40 +0100, John Wong wrote:
> Hi gmane.emacs.w3m developers and users,

> First of all thanks for your contributions: I have been using emacs-w3m
> without problem under windows 32-bit and Cygwin 32-bit.

> Recently, I switched to windows 64-bit (under Windows 10) and found out
> that my Emacs doesn't load w3m despite putting the old good emacs-w3m files
> in the old path.

I'm now on 32-bit Cygwin on 32-bit Windows 10 and using Emacs 25
built on Cygwin.

> I tried to compile both the CVS version and the stable version according to
> the instructions but the ./configure file stopped before creating a
> Makefile. Here is the output:
> wong@emacs-w3m-1.4.4[580] cat ./configure.in
> wong@emacs-w3m-1.4.4[581] ./configure
> checking whether make sets $(MAKE)... yes
> checking for a BSD-compatible install... /usr/bin/install -c
> checking for makeinfo... makeinfo
> checking for texi2dvi... false
> checking for ptex... ptex
> checking for jbibtex... false
> checking for egrep... egrep
> checking for emacs... /cygdrive/c/Program Files (x86)/GNU Emacs
> 24.5/bin/emacs
> checking what a flavor does /cygdrive/c/Program Files (x86)/GNU Emacs
> 24.5/bin/emacs have...
> wong@emacs-w3m-1.4.4[582]

Well, is Emacs executable you use the Windows version?  If so,
do you really want to use it rather than Cygwin's /usr/bin/emacs?

;; To let the configure script use Cygwin's Emacs, add /usr/bin
;; (or /bin) to the top of the PATH environment variable.

I've never used the Emacs executable of the Windows version, so
I tried "/cygdrive/c/Program Files/GNU Emacs 24.5/bin/emacs.exe"
that is a copy of "/usr/local/bin/emacs.exe", and got a similar
problem.  I guessed the cause is space characters in the path
name of Emacs.  Could you try the attached patch?  This aims to
the latest emacs-w3m in CVS, so use it as follows when you try:

% cvs -d :pserver:anonymous@xxxxxxxxxxxxxx:/storage/cvsroot login
  CVS password: (Just hit Enter/Return key)
% cvs -d :pserver:anonymous@xxxxxxxxxxxxxx:/storage/cvsroot co emacs-w3m
% cd emacs-w3m
% patch < SOMEWHERE/aclocal.patch
% autoconf
% ./configure


Attachment: aclocal.patch
Description: A patch to aclocal.m4