[Date Prev][Date Next][Thread Prev][][Date Index][Thread Index]

Re: No images! No dumb T stuff

Thanks for reporting to us, Rahul.

On 2018-09-11 20:18, Rahul Juliato wrote:
>    Please write in simple English, because the emacs-w3m developers
>    aren't good at English reading. ;-)


I'm not able to reproduce the bug. (@Rahul: Please follow these steps so
we can be sure that we are doing the same thing):

1) Verify that I'm using a clean upstream version.

2) My version is 1.4.629, which is seven commits ahead of Rahul's, so
   maybe Rahul could try updating.

   I just now looked and see that the latest Fedora package seems to be
   newer (1.4.631 ??), and the MELPA package is dated April, so it's an
   older version. Taking a look at the underlying MELPA repository
   https://github.com/ecbrown/emacs-w3m indicates it hasn't been updated since
   March, so it's even older than MELPA indicates.

   @Rahul, the only official emacs-w3m package is the one downloaded
   from the project website via CVS. The fedora & MELPA packages are
   great and convenient, but they are done without any co-ordination
   with the project, and for a long, long time we didn't even know they
   existed. Do be careful not to mix-and-match versions; it can get
   confusing if Fedora puts one version in your $PATH and its custom
   emacs-load-path, and then MELPA does, and then you do.

   Anyway, let's continue.

3) Launch emacs this way: \emacs -Q

4) Evaluate the following lines, but first insert the actual load path.

   (add-to-list 'load-path "/your/path/to/emacs-w3m")
   (setq w3m-default-display-inline-images t)
   (setq w3m-display-inline-images t)
   (setq w3m-default-display-inline-images t)
   (require 'w3m))

5) M-x w3m

6) g some-simple-site-with-a-few-images

   Worked for me with xkcd.com & google.com

>    ================================================================
>    Dear Bug Team!
>    Hello!
>    I have w3m on emacs.
>    1.) w3m by it self works perfectly on both tty and xterm
>    From here on, everything is on X.
>    2.) w3m works fine on emacs, the splash screen shows the image of
>    emacs-w3m.
>    And that's it, no other image is shown visiting any site.
>    This are set:
>    (setq w3m-default-display-inline-images t)
>    (setq w3m-display-inline-images t)
>    (setq w3m-default-display-inline-images t)
>    I used toggle on every page I get, so the status bar shows IMG and or
>    IMG(SSL).
>    I tried with a html page in my computer, and it also shows no images.
>    If I load an image url that ends with .pgn, .jpg, .gif, surprise! It
>    shows a buffer with the image.
>    If on a page, I point to a place where it should be an image and ask
>    w3m
>    to download, and or show. It just hangs on forever, never saving and/or
>    opening it.
>    This all is true for both emacs-w3m package on fedora and the emacs-w3m
>    package on melpa.
>    Any help?
>    Thanks!
>    ================================================================
>    System Info to help track down your bug:
>    ---------------------------------------
>    emacs-w3m-version
>     => "1.4.622"
>    emacs-version
>     => "GNU Emacs 25.3.1 (x86_64-redhat-linux-gnu, GTK+ Version 3.22.26)\n
>    of 2018-06-27"
>    mule-version
>     => "6.0 (HANACHIRUSATO)"
>    system-type
>     => gnu/linux
>    (featurep 'gtk)
>     => t
>    w3m-version
>     => "w3m/0.5.3+git20180125"
>    w3m-type
>     => w3m-m17n
>    w3m-compile-options
>     => ("lang=en" "m17n" "image" "color" "ansi-color" "mouse" "gpm" "menu"
>    "cookie" "ssl" "ssl-verify" "external-uri-loader" "w3mmailer" "nntp"
>    "gopher" "ipv6" "alarm" "mark")
>    w3m-language
>     => nil
>    w3m-command-arguments
>     => nil
>    w3m-command-arguments-alist
>     => nil
>    w3m-command-environment
>     => (("LC_ALL" . "C"))
>    w3m-input-coding-system
>     => utf-8
>    w3m-output-coding-system
>     => utf-8
>    w3m-use-mule-ucs
>     => nil

CA45 09B5 5351 7C11 A9D1  7286 0036 9E45 1595 8BC0