[Date Prev][Date Next][Thread Prev][][Date Index][Thread Index]

Re: emacs-w3m doesn't work

Katsumi Yamaoka <yamaoka@jpl.org> writes:

> Hi,


> Last week, I've forwarded your message posted to comp.emacs to
> the emacs-w3m list.  However, there's no response so far.

Yes. I've seen it in the web archive.

> Doesn't emacs-w3m work even for local web pages?  To check it,
> type `M-x w3m-history RET' for example and you will see a
> history page.  You can also check it by accessing web servers in
> the intranet.

Hm. The w3m-history has only <about:> listed. Now I'm in my university
and try to access the university's web server. But I only get "Location:
http://www.uni-koblenz-landau.de/"; in my *w3m* buffer and "Reading
http://www.uni-koblenz-landau.de/favicon.ico...done (no favicon)" in my

I've tested with using the IP instead of the URL, too. The I have the
same in my *w3m* buffer and "Fontifying...done" in the minibuffer.

But displaying local (file:///home/heimdall/...) html-content works

> Do you need the proxy server to access foreign web sites? 

No. Not at home. Here in my university I need a proxy to access sites
out of the local net. But all pages inside the intra net can also be
viewed without. 
I tested all pages with w3m in a terminal emulator and without having a
proxy configured.

> If so, there are several ways to specify it.  One is to set the
> `http_proxy' environment variable which is referred to by the w3m
> executable.  Note that it should be set in the shell in which Emacs
> starts.  For instance:
> http_proxy='http://proxy.uni-koblenz.de:8000/'; export http_proxy
> emacs -f w3m 'http://www.google.de/'

I tried this with the correct proxy settings, but then I got

Location: http://www.google.de/
Cannot retrieve URL: http://www.google.de/ (exit status: 0)
www.google.de could not be found. Please check the name and try again

in my *w3m* buffer.

To ensure the proxy works I tried the same settings with konqueror and
then it works... (And it works with this proxy settings with w3m in a

> Well, if you have a direct access to the Internet, I have
> currently no more ideas.

Me, too. :-(

Just to summarize: It seems to be a network problem, because rendering
local web sites works fine. But it is not a proxy problem. I can access
all external (at the university with proxy / at home without) and
internal sites with w3m in a terminal.

One last thing.  C-c C-b sayed that w3m-type was 'w3m-i17n, but I have
w3m installed. Is this correct?  I've tested emacs-w3m with (setq
w3m-type 'w3m), but this didn't change anything.

Thanks for your help,
	"I love the smell of jet fuel in the morning!"