[Date Prev][Date Next][Thread Prev][][Date Index][Thread Index]

Re: emacs-w3m doesn't work

We got some hints thanks to Shun-ichi Goto.  Here's a summarized

>>>>> In [emacs-w3m : No.07051] Shun-ichi Goto wrote:

>>>>>> On Mon, 23 Aug 2004 15:36:36 +0200, Tassilo Horn wrote,

>> I tried this with the correct proxy settings, but then I got

>> Location: http://www.google.de/
>> Cannot retrieve URL: http://www.google.de/ (exit status: 0)
>> www.google.de could not be found. Please check the name and try again

gotoh> That the failure differs from others looks strange.

Indeed.  I have no idea for it, though.

gotoh> Although I'm not sure of it, that w3m provides the `ipv6'
gotoh> feature doesn't influence something, does it?

Hm, my w3m also provides it, but there seems to be no problem.

gotoh> Don't you load some libraries using the LD_PRELOAD
gotoh> environment variable, for example?  It may be able to
gotoh> check by running `M-x shell' and `w3m' or `w3m -dump_head'.

That seems a good idea.  Tassilo, how about it?  I tried it in
the Emacs shell buffer as follows, and confirmed w3m worked.

TERM=vt100; export TERM
w3m -dump_head http://www.google.de/

w3m http://www.google.de/
C-c C-c

;; A private note to Goto-san:
;; 後藤さん、じかに英語で書いてくれた方が話が早いですよ。;-)
;; ともあれ、ありがとうございます。