[Date Prev][Date Next][Thread Prev][][Date Index][Thread Index]

Re: emacs-w3m doesn't work

Katsumi Yamaoka <yamaoka@jpl.org> writes:

Hi Katsumi,

thanks for dedicating so much time to helping me!

> gotoh> Don't you load some libraries using the LD_PRELOAD
> gotoh> environment variable, for example?  It may be able to
> gotoh> check by running `M-x shell' and `w3m' or `w3m -dump_head'.
> That seems a good idea.  Tassilo, how about it?  I tried it in
> the Emacs shell buffer as follows, and confirmed w3m worked.
> TERM=vt100; export TERM
> w3m -dump_head http://www.google.de/

(%:~)- w3m -dump_head http://www.uni-koblenz.de/         
HTTP/1.1 200 OK
Date: Tue, 24 Aug 2004 12:15:31 GMT
Server: Apache/1.3.27 (Linux/SuSE) mod_ssl/2.8.12 OpenSSL/0.9.6i PHP/4.3.1 mod_perl/1.27 mod_layout/3.0 mod_gzip/ DAV/1.0.3
Last-Modified: Wed, 07 Jul 2004 09:56:53 GMT
ETag: "12503852-2b75-40ebc8e5"
Accept-Ranges: bytes
Content-Length: 11125
Keep-Alive: timeout=15, max=100
Connection: Keep-Alive
Content-Type: text/html

Seems to be ok.

> w3m http://www.google.de/
> C-c C-c

Works. I can browse the web...
I tested with M-x term instead of M-x shell, which has problems with my
prompt setting. But this doesn't make a difference, does it?

Gnus gives you all the opportunity you could possibly want for
shooting yourself in the foot. 
                  - taken from the Gnus INFO page -