[Date Prev][Date Next][Thread Prev][][Date Index][Thread Index]

Re: From newbie: problems with installation of w3m

Rodolfo Medina wrote:

> From http://emacs-w3m.namazu.org I downloaded the package
> but the README file tells to install w3m before installing emacs-w3m .
> So I downloaded the package w3m-0.5.1.tar.gz and tried to install it,
> but in the './configure' step I go on getting the message:
> configure: error: gc.h not found

Tsuyoshi CHO wrote:

> This error message means configure script do not found "Boehm GC"
> Library header.
> Currentry, w3m 5.0 or higher does not contain GC Library.
> Please install before w3m compile.
> -> http://www.hpl.hp.com/personal/Hans_Boehm/gc/
> emacs-w3m installation are following steps:
>  1. compile & install GC library.
>  2. compile & install w3m.
>  3. compile & install emacs-w3m.


As you suggested, from http://www.hpl.hp.com/personal/Hans_Boehm/gc/
I downloaded the package gc.tar.gz, and installed it with '$ ./configure',
`$ make', `$ make check' and `# make install'.
The installation seemed to be successful.
Then I tried again to install w3m-0.5.1.tar.gz,
but at the  end of `./configure' I got the following error message:

checking size of long long... configure: error: cannot compute sizeof (long
long), 77
See `config.log' for more details.

. Sorry, I'm not linux expert. Could you provide further suggestion?

Thanks indeed,