[Date Prev][Date Next][Thread Prev][][Date Index][Thread Index]

Re: From newbie: problems with installation of w3m

Tsuyoshi CHO wrote:
> emacs-w3m installation are following steps:
>  1. compile & install GC library.
>  2. compile & install w3m.
>  3. compile & install emacs-w3m.

Rodolfo Medina wrote:

> From http://www.hpl.hp.com/personal/Hans_Boehm/gc/
> I downloaded the package gc.tar.gz, and installed it with '$ ./configure',
> `$ make', `$ make check' and `# make install'.
> The installation seemed to be successful.
> Then I tried again to install w3m-0.5.1.tar.gz,
> but at the  end of `./configure' I got the following error message:
> checking size of long long... configure: error: cannot compute sizeof
(long long), 77
> See `config.log' for more details.

Masaru Nomiya wrote:

> Mr. Yamaoka gave answer already. :-)
KY> My best guess is that you have Boehm GC installed in non-standard
KY> `lib' directory, like /usr/local/lib/libgc.*.  /usr/local/lib is
KY> standard of course, however the w3m installer doesn't treat it so.
KY> I'm not an exception, and am always annoying with it.  My solution
KY> is to set the LDFLAGS environment variable as /usr/local/lib before
KY> building w3m.

KY> Oops, sorry.  That's wrong.  The correct way is setting the
KY> LDFLAGS environment variable as:

KY> '-Xlinker -R/usr/local/lib'

I tried with: '$ export LDFLAGS=-Xlinker -R/usr/local/lib'
but got the following output:

[rodolfo@localhost rodolfo]$ export LDFLAGS=-Xlinker -R/usr/local/lib
bash: export: `-R/usr/local/lib': not a valid identifier

. Then I tried with '$ export LDFLAGS=/usr/local/lib',
but then when I did '$ ./configure' I got:

[rodolfo@localhost w3m-0.5.1]$ ./configure
checking for gawk... gawk
checking for gcc... gcc
checking for C compiler default output file name... configure: error: C
compiler cannot create executables
See `config.log' for more details.

The same happened with '$ set LDFLAGS=/usr/local/lib'.
Then I tried with '$ LDFLAGS=-Xlinker -R/usr/local/lib' but got:

[rodolfo@localhost w3m-0.5.1]$ LDFLAGS=-Xlinker -R/usr/local/lib
bash: -R/usr/local/lib: No such file or directory

. Excuse my unexperience again, but what should the correct syntax be
to set the LDFLAGS environment variable as '-Xlinker -R/usr/local/lib',
as Mr. Yamaoka suggests?
I'm attaching config.log once more.

Thanks indeed,

Attachment: config.log
Description: Binary data