[Date Prev][Date Next][Thread Prev][][Date Index][Thread Index]

Re: From newbie: problems with installation of w3m

Tsuyoshi CHO wrote:
> emacs-w3m installation are following steps:
>  1. compile & install GC library.
>  2. compile & install w3m.
>  3. compile & install emacs-w3m.

Rodolfo Medina wrote:

> From http://www.hpl.hp.com/personal/Hans_Boehm/gc/
> I downloaded the package gc.tar.gz, and installed it with '$ ./configure',
> `$ make', `$ make check' and `# make install'.
> The installation seemed to be successful.
> Then I tried to install w3m-0.5.1.tar.gz,
> but at the  end of `./configure' I got the following error message:
> checking size of long long... configure: error:
> cannot compute sizeof (long long), 77
> See `config.log' for more details.

Masaru Nomiya wrote:

> Mr. Yamaoka gave answer already. :-)
> KY> My best guess is that you have Boehm GC installed in non-standard
> KY> `lib' directory, like /usr/local/lib/libgc.*.  /usr/local/lib is
> KY> standard of course, however the w3m installer doesn't treat it so.
> KY> I'm not an exception, and am always annoying with it.  My solution
> KY> is to set the LDFLAGS environment variable as /usr/local/lib before
> KY> building w3m.
> KY> Oops, sorry.  That's wrong.  The correct way is setting the
> KY> LDFLAGS environment variable as:
> KY> '-Xlinker -R/usr/local/lib'

After gc.tar.gz installation I did:

$ export LDFLAGS="-Xlinker -R/usr/local/lib"

, then tried again to install w3m-0.5.1.tar.gz with
$ ./configure', '$ make' and '# make install',
and this time the ./configure step seemed to have no problem;
but when I did '$ make' I got the following output:

[rodolfo@localhost w3m-0.5.1]$ make
(echo '#define DEFUN(x,y,z) x y';\
 sed -ne '/^DEFUN/{p;n;/^[      ]/p;}' ./main.c ./menu.c) | gcc -E - | \
 awk '$1 ~ /^[_A-Za-z]/ { \
       for (i=2;i<=NF;i++) { print $i, $1} \
 }' > funcname.tab.tmp
funcname.tab updated
sort funcname.tab | gawk -f ./funcname1.awk > funcname1.h
gcc  -I. -I. -g -O2 -I./libwc  -DHAVE_CONFIG_H -DAUXBIN_DIR=\"/usr/local/lib
exec/w3m\" -DCGIBIN_DIR=\"/usr/local/libexec/w3m/cgi-bin\" -DHELP_DIR=\"/usr
/local/share/w3m\" -DETC_DIR=\"/usr/local/etc\" -DCONF_DIR=\"/usr/local/etc/
w3m\" -DRC_DIR=\"~/.w3m\" -DLOCALEDIR=\"/usr/local/share/locale\"   -c -o
main.o main.c
In file included from fm.h:39,
                 from main.c:3:
html.h:5:25: openssl/bio.h: No such file or directory
html.h:6:26: openssl/x509.h: No such file or directory
html.h:7:25: openssl/ssl.h: No such file or directory
In file included from html.h:10,
                 from fm.h:39,
                 from main.c:3:
istream.h:30: error: syntax error before "SSL"
istream.h:30: warning: no semicolon at end of struct or union
istream.h:32: error: syntax error before '}' token
istream.h:116: error: syntax error before '*' token
istream.h:129: error: syntax error before '*' token
make: *** [main.o] Error 1

Tsuyoshi CHO wrote:

> I think this problem is mainly w3m's compling issue.
> Next mail if you have more problem, please you add "w3m developer en ML"
> <w3m-dev-en@mi.med.tohoku.ac.jp> to "To:" or "Cc:" Address field and
> problem summary.

I did so: I subscribed to w3m-dev-en mailing list
and sent my problem summary to both the adresses
'w3m-dev-en@sic.med.tohoku.ac.jp' and 'w3m-dev-en@mi.med.tohoku.ac.jp',
but got no answer.

Mito wrote:

> I did,
> $ cd /tmp/gc6.3
> $ ./configure --enable-shared=no
> $ make
> $ LDFLAGS='-L/tmp/gc6.3/.libs'
> $ export LDFLAGS
> $ cd ~/w3m-0.5.1
> $ ./configure --with-gc=/tmp/gc6.3
>       :
> This make w3m link gc statically.

Thanks: I tried your suggestion, but again I got the output:

checking for long long... yes
checking size of long long... configure: error: cannot compute
sizeof (long long), 77
See `config.log' for more details.

I'm really stuck...
Any other hint?