[Date Prev][Date Next][Thread Prev][][Date Index][Thread Index]

Re: html images still not viewed in gnus [was: From newbie: problems with installation of w3m]

Rodolfo Medina wrote:

> After some difficulties, in the end I managed to install
> emacs-w3m in my system, but still can't view images within html mails,
> with gnus.
> [...]
> Before installing emacs-w3m, I installed the following packages:
> gc.tar.gz; openssl-0.9.7e.tar.gz; w3m-0.5.1.tar.gz.
> I don't know if it's important, but during the 'make' step
> in the installation of openssl-0.9.7e.tar.gz
> the following message went on appearing:
> `-mcpu=' is deprecated. Use `-mtune=' or '-march=' instead.
> No other problems seemed to occur.
> [...]
> In my .emacs I put:
> (require 'w3m-load)
> , and in my .gnus.el I put:
> (setq mm-inline-text-html-renderer 'w3m)
> (setq mm-inline-text-html-with-images t)
> (setq mm-w3m-safe-url-regexp nil)

Katsumi Yamaoka wrote:

> Please read the Info manual by typing:
> M-x info RET d m Emacs-w3m RET m Gnus RET C-s Notes

Yes, I know html images are mostly spam, but sometimes they could be
of interest for me and I don't want to miss them.


> First of all, I storongly recommend you make it possible to read
> the Info manual.  I think you might be able to find a solution
> by yourself.
> (We are very busy answering to too basic questions even though
> we only have the same time that you have.  Although any
> questions are welcome, you should read the manuals, including
> the Emacs manual, and do all you can in advance.)

That's exactly what I did: before sending my last message I read
carefully the emacs-w3m info manual and tried to follow
all the indications there given, without finding
an answer to the problems I'm encountering in viewing html images.
On the other hand, the question might be not too basic if you say
(see below) you can't find out what blocks me to see inline images
after all.


> Make sure things listed below are what they should be.
> * In the /usr/local/info/ directory, there are files of which
>   names begin with `emacs-w3m' (e.g., emacs-w3m.info,
>   emacs-w3m.info-1, ...).  If not, try to install emacs-w3m
>   again, and confirm where those files are installed.  The
>   directory can be altered using the `--infodir=' configure
>   option.

In the /usr/local/info directory there are the following files
whose names begin with `emacs-w3m':

emacs-w3m.info, emacs-w3m-ja.info, emacs-w3m-ja.info-1, emacs-w3m-ja.info-2,
emacs-w3m-ja.info-3, emacs-w3m-ja.info-4.


> * In the /usr/local/info/dir file, there is the entry which
>   begins with `* Emacs-w3m:'.  If not, add it to the file like
>   the following:
>   % su root
>   # echo '* Emacs-w3m: (emacs-w3m). An Emacs interface to w3m' >>

In the /usr/local/info/dir file, there is the following:

GNU Emacs Lisp
* Emacs-w3m: (emacs-w3m).  An Emacs interface to w3m
* Emacs-w3m-ja: (emacs-w3m-ja).  An Emacs interface to w3m (Japanese)
* URL: (url).                 URL loading package.


> * Start Emacs and make sure the `Info-default-directory-list'
>   Lisp variable contains the dirctory named `/usr/local/info/'
>   (it might be `/usr/local/info').  To know the value for the
>   variable, type `C-h v' (or `M-x describe-variable RET') for
>   it.  If not, put the following lines in your ~/.emacs file.
> (setq Info-default-directory-list
>       (cons "/usr/local/info/" Info-default-directory-list))
> (eval-after-load "info"
>   '(setq Info-directory-list Info-default-directory-list))

I did: C-h v RET Info-default-directory-list RET,
and the following appeared:

Info-default-directory-list's value is
("/usr/local/info/" "/usr/local/share/info/" "/usr/local/gnu/info/"
"/usr/local/gnu/lib/info/" "/usr/local/gnu/lib/emacs/info/"
"/usr/local/emacs/info/" "/usr/local/lib/info/" "/usr/local/lib/emacs/info/"
"/usr/share/info/" "/usr/local/info/")


> I'm attaching all the steps I followed during the installation of
> emacs-w3m.


> Hm, I couldn't find out what blocks you to see inline images
> after all.
> [...]
> Can you see this image?
> [...]
> the image in this message should be viewed if your Emacs
> supports the png image format.

I could see the image on my mail server website, before downloading it,
and I can see it very well in MS Outlook (which I'm still using expecting
to migrate to gnus); instead, when I downloaded your message via gnus
I couldn't see the image. In its place the following line appears:


Any idea?
Regards, and thanks again for your help,