[Date Prev][Date Next][Thread Prev][][Date Index][Thread Index]

Re: emacs-w3m cannot quit from a w3m-session

Katsumi Yamaoka <yamaoka@xxxxxxx> writes:

>>>>>> In [emacs-w3m : No.09813] Katsumi Yamaoka wrote:
>> I guess it happens because a url that is an empty string has been
>> registered (or is about to be registered) in your "~/.w3m/.arrived"
>> file.  Isn't there a line that begins with
>>  (""
>> in that file?

Yes, the entry was this:

  "Directory list of /home/andy/.w3m/"
  (17867 20235 881557)

As you said, removing that entry solved the problem.

> Naohiro Aota discovered a special case where such a funny one is
> generated[1].  For example, if the `w3m-goto-url' function is
> called non-interactively with the argument "/" as a url[2], or
> if a user set the `w3m-home-page' variable to "/", it will be
> normalized[3] into "".  Isn't it your case?

Considering the case you explained above, it seems strange that the
Directory listing of /home/andy/.w3m/ triggered the generation of that
empty string.

I tried to open with emacs-w3m the url: file:///home/andy/.w3m/ without
the patch form Naohiro, and the resulting entry in ~/.w3m/.arrived is:

  "Directory list of /home/andy/.w3m/"
  (18263 61513)
  (18263 61510 425407)

which is correct.

I can't reproduce the situation in which opening that url will end up in
an entry with an empty string.  It is entirely possible that the problem
happened in one of my debugging/experimentation sessions.

>  Anyway, the code in question has already been fixed in CVS thanks to
> Naohiro Aota.  Could you try it?

I tried it by evaluating this sexp: `(w3m-goto-url "/")' and it worked;
no empty string in the `~/.w3m/.arrived' file.

Many thanks for your help.

With my best wishes,

In a world where everything is a bitstream, where the marginal cost of
culture is zero, everything can be given to everybody at the same
costs that it was given to its first possessor, it is immoral to
exclude people from knowledge and from beauty.  -- Eben Moglen