[Date Prev][Date Next][Thread Prev][][Date Index][Thread Index]

Re: w3m-ems.el problem?

>>>>> In [emacs-w3m : No.09992] Evans Winner wrote:

> Hello.  I just did a `make bootstrap' on the current Emacs
> trunk yesterday (just after the Unicode branch was merged).
> I found that afterward, gnus stopped rendering html email.

In general, byte codes compiled by the older versions of Emacs
are incompatible with the most recent Emacs CVS, though some (in
which there's no non-ASCII string?) might work.

> I figured out that if I tried M-x w3m I had the same error:
> `Wrong type argument: arrayp, nil'.

I could reproduce the same error with the latest Emacs head
using emacs-w3m compiled by the Emacs that is a bit old.

> I can't seem to debug
> the problem.  First I did a `cvs up' on emacs-w3m, and
> rebuilt it.  I tried `emacs -Q' and then loaded w3m and it
> worked, then I tried `emacs -Q' and manually loaded
> libraries in my .emacs one at a time, trying w3m as I went,
> and it never failed.

> I found that if I loaded w3m manually, it put me in a
> debugger saying the error was in w3m-ems.  I then found that
> if I went into w3m-ems.el and did `eval-buffer' all worked,
> but if I tried to (require 'w3m-ems) it failed with the same
> error (with or without a matching .elc).  So, the upshot is,
> I haven't figured out how to isolate the error.  Sorry.  If
> anyone wants, I can probably provide more information, but
> right now I am not sure what might be relevant.

> Hope this is useful.

Thanks.  Anyway people who use the version of Emacs that has
merged the Unicode-2 branch all have to rebuild every ELisp
program that is not a part of Emacs.  Unfortunately, .elc files
built with the older Emacs never report that they cannot be used
with the newer Emacs by themselves.