[Date Prev][Date Next][Thread Prev][][Date Index][Thread Index]

Re: error in post-command-hook

Thierry Volpiatto <thierry.volpiatto@xxxxxxxxx> writes:

> Hi,
> i am working on a little interface of w3m bookmarks in anything.
> When i open multi tab in w3m from anything, after quitting anything,
> if i try to move in the tabs i have this error:
> ,----
> | Error in post-command-hook: \ 
> | (wrong-type-argument symbolp #[nil \300\301!\207 [w3m-previous-buffer 1] 2 nil nil])
> `----
> However the action (precedent tab or next tab) work fine even with this
> error message.
> After one switch, the error disapear. (w3m set up some variables ?)
> Any idea ?
> You can find the code for w3m bookmarks in anything at:
> http://www.emacswiki.org/emacs/AnythingConfigThierryVolpiatto.el

I've tried to reproduce the problem, but couldn't make "(anything
'anything-c-source-w3m-bookmarks)" worked. (I don't use "anything"

Posting backtrace could help us to solve the problem.

1. M-x toggle-debug-on-error
2. Do things to raise error.
3. A buffer named "*Backtrace*" would appear.
4. Save its contents to a file, and attach the file.