[Date Prev][Date Next][Thread Prev][][Date Index][Thread Index]

Re: trouble with installation


In [emacs-w3m : No.11228] Paul Burkander wrote:
> I'm having a great deal of difficulty getting emacs-w3m going, and I'm
> wondering if anyone can help me out?

> I'm using Ubuntu 10.04.  I have w3m 0.5.2-2.1ubuntu1 and w3m-el
> 1.4.4-9 installed via the synaptic package manager, as well as emacs
> 23.1+1-4ubuntu7.

> I have (require 'w3m-load) in my .emacs; however, when I start emacs,
> I get the following message:

> "Cannot open load file, w3m-load"

> When I type M-x w3m, it says there is no match.

> Does anybody know what I am doing wrong?  I've tried reinstalling
> w3m-el many times!

First of all does w3m-load.el exist in one of Emacs' `load-path'
directories?  To see it, perform this command:

M-x locate-library RET w3m-load RET

I don't know what's going on in w3m-el 1.4.4-9.  I tried building
emacs-w3m from w3m-el_1.4.4.orig.tar.gz and w3m-el_1.4.4-9.diff.gz
and confirmed that the w3m-load.el file is surely generated, though.
But AFAICT it's very old.  How about trying the most recent
development version of emacs-w3m?  You can get it as:

wget http://cvs.namazu.org/emacs-w3m.tar.gz

See the README file for the installation.  After performing autoconf,
you can see the configure options by:

./configure --help

And you can see what modules will be installed in what places by
performing (after running ./configure options...):

make what-where

(IMHO, Expert users and developers don't seem to be interested
 in the old emacs-w3m versions, so we all would be saved if you
 would talk about the most recent one.)