[Date Prev][Date Next][Thread Prev][][Date Index][Thread Index]

Re: Wrong type error when calling all functions

On 12/19/10 8:34 PM, Katsumi Yamaoka wrote:
In [emacs-w3m : No.11453] Chris Thompson wrote:
Hi, I am having trouble installing emacs-w3m on an intel-mac. I have w3m
running in terminal. I have tried pointing emacs-w3m makefile to
directories that I believe to be correct. I don't get an error from
(require 'w3m-load), but when I call any w3m functions the message says:
Wrong type argument: array-p, nil.  I'm not sure how to investigate what
is wrong, thanks for your help.
What version of emacs-w3m do you use?  Or where did you get the
emacs-w3m source from?  The latest one is as:


With this, w3m-load.el should be found in the same directory where
w3m.elc has been installed.  Try:

M-x locate-library RET w3m RET

Is the directory where you believe that emacs-w3m has been installed?
locate-library for w3m, org, abbrev and others return this directory:

I installed emacs from homebrew. It looks like there is a mistake in that install script, but I haven't looked into it.

I was't able to build the package that you linked to. I really only know configure, make, make install. What would I need to do to build the package you linked too? However, I did build 1.4.4 from the same server.
I rebuilt it just now with the lispdir variable in the makefile equal to the above path. Now locate-library w3m gives the above path. So the w3m.ecl is in the same directory as w3m-load.el. Unfortunately I am getting the same error- Wrong type argument: array-p, nil.

Perhaps I should try a reinstall of emacs?
Thanks a lot for your help,