[Date Prev][Date Next][Thread Prev][][Date Index][Thread Index]

Re: emacs-w3m doesn't create Makefile (using Windows 10 64-Bit with Cygwin64)

In [emacs-w3m : No.12539]
	On Thu, 26 Nov 2015 15:32:13 +0100, John Wong wrote:
> I think the problem is rather install-info cannot tell that the directory
> actually exists.

Oh, sorry, you're right.  `man install-info' says:
|  install-info [OPTION]... [INFO-FILE [DIR-FILE]]
|  Add  or  remove  entries in INFO-FILE from the Info directory DIR-FILE.
|  INFO-FILE  and  DIR-FILE  are  required  unless  the   --info-file   or
|  --dir-file (or --info-dir) options are given, respectively.
So, I tried

$ install-info /cygdrive/c/Program\ Files/GNU\ Emacs\ 24.5/share/info/{emacs-w3m.info,dir}


$ install-info --info-dir=/cygdrive/c/Program\ Files/GNU\ Emacs\ 24.5/share/info /cygdrive/c/Program\ Files/GNU\ Emacs\ 24.5/share/info/emacs-w3m.info

and confirmed both work.  Probably I made a mistake on copying
the command line I tried yesterday.  Sorry again.

Anyway, I'll add this issue to the TODO list:

Pass a Cygwin path name to `install-info' when installing info
files for Windows Emacs by using Cygwin.