[Date Prev][Date Next][Thread Prev][][Date Index][Thread Index]

Re: Form reuse doesn't update content [PATCH]

On 2018-04-04 11:21, Katsumi Yamaoka wrote:
> In [emacs-w3m:12946]
> >> In [emacs-w3m:12943]
> >> On Fri, 30 Mar 2018 04:13:29 -0400, Boruch Baum wrote:
> >>> I was using emacs-w3m to edit a wiki, which initially worked flawlessly.
> >>> However, when I attempted to edit the page a second time, the data in
> >>> the w3m form edit window buffer did not update its content. What I mean
> >>> is that it had the original text of the page prior to the first edit.
> Sorry, could you let me know where/how I can reproduce this
> problem?  I tried it in wikipedia's sandbox, some translation
> sites, etc., but everything worked as expected.

1] Go to a page on emacswiki, say

2] Perform an edit, such as inserting a test message, or a single
   unobtrusive symbol that no-one would notice, and save the edit.

3] Navigate away from the page. Maybe visit the the page you just edited
   just to be sure that the edit tookhold.

4] Navigate back to the page.

5] The textarea content of the edit box does not include your (my)
   recent edit. Rather, it remains the same as when you (I) first visited
   the page.

CA45 09B5 5351 7C11 A9D1  7286 0036 9E45 1595 8BC0