[Date Prev][Date Next][Thread Prev][][Date Index][Thread Index]

Re: emacs-w3m doesn't create Makefile (using Windows 10 64-Bit with Cygwin64)

In [emacs-w3m : No.12542]
	On Fri, 04 Dec 2015 17:16:53 +1100, Kevin Ryde wrote:
> Slightly off-topic, but do you use your own build of w3m itself, or
> is there a good place to get a binary?

I normally use the ones that I built by myself from the source[1]
on both the office pc (Cygwin on Windows 10) and the home pc
(Fedora 23), but have no problem on using the ones Cygwin and
Fedora distributed.  Do you mean the w3m binary of Windows-native?
No, I've ever tried neither building nor downloading it.  For Emacs
24.5 of Windows-native I tried recently, I used Cygwin's w3m.

> I suffered the indignity of a bare windos 8 (or some version)
> recently.  Got as far as perl and emacs and thought emacs-w3m too
> could be good.  The w3m faq mention of binaries seems slightly gone,
> unless I've mis-followed it.

That's probably right, doesn't look well maintained.  But many
Unix-like systems bundle w3m in its distribution nowadays, so
I guess most people use it and they might not be troubled with
getting the w3m binary.  For Windows, I found the Japanese page:

 -> <http://hp.vector.co.jp/authors/VA052357/w3m-0.5.3-mingw32.zip>
(Haven't tried it yet, though)

[1] git clone git://anonscm.debian.org/collab-maint/w3m.git
./configure; make LDFLAGS='-Xlinker -R/usr/local/lib -lX11'