[Date Prev][Date Next][Thread Prev][][Date Index][Thread Index]

Re: bookmark file not reloaded until w3m restart

Boruch Baum wrote:

> Have you tried the following?
>   M-x w3m-reload-this-page

Yes, not only have I tried it, that is what
doesn't work :) Even closing the tab and
opening a new one and browsing the bookmark
file will give me the old version.

The only way to do it that I've discovered is
to close Emacs-w3m and start it anew, then
it works.

> If your final decision is to use the
> up-to-date emacs-w3m version from MELPA,
> then: 1) you need to remember to update ALL
> your elc files (ie. rm *.elc and then
> byte-compile) when you update the el files,
> and; 2) you don't need to perform any
> apt pinning.

I tried to use the most recent Emacs-w3m
version from MELPA by first doing

    $ sudo apt-get purge w3m-el-snapshot

and then installing it from MELPA, but I got
the variable error.

I didn't manually go about removing any *.elc
files or did any manul byte-compile of the
source, I just did the 'purge' and then the
MELPA install from within Emacs.

Anyway I don't get the error with the Debian
testing version of w3m-el-snapshot, which I get
thru apt pinning.

> Personally, I avoid byte-compiling because of
> too many bitter experiences of the kind you
> encountered. I haven't noticed any
> performance difference.

I never manually byte-compile MELPA packs (not
that I use that many, either) but I do
byte-compile my Elisp [1] with this
Makefile [2]. It is not only about performance,
it is also about the byte-compiler finding bugs
and overall increasing the quality of
your code. Here is my code WRT Emacs-w3m [3].

[1] https://dataswamp.org/~incal/emacs-init/

[2] http://user.it.uu.se/~embe8573/emacs-init/Makefile

[3] https://dataswamp.org/~incal/emacs-init/w3m/

underground experts united