[Date Prev][Date Next][Thread Prev][][Date Index][Thread Index]

Re: jde + emacs-w3m problem


Unfortunately, it seems very hard for me to begin to use JDE.
It requires SEMANTIC, EIEIO..., what is avltree? Hmm...  Can
anyone help it?  Otherwise, if you can get the Lisp backtrace,
someone may possibly be able to solve the problem.  To do that:

Evaluate the following form:

(setq debug-on-quit t)

Type the C-g key when Emacs hangs.

>>>>> In [emacs-w3m : No.05843]
>>>>>	"Jose A.Ortega Ruiz" <jao@member.fsf.org> wrote:

> hi,

> i'm using emacs 21.3.1 with emacs-w3m 0.4.2 and jde 2.3.3beta6
> (although my problem is exactly the same with jde 2.3.2) on a debian
> unstable box.

> when i launch the emacs-w3m _after_ loading jde, the emacs-w3m browser
> hangs when fontifying any web page i visit. emacs just freezes, and
> i've noticed that it is consuming almost all the cpu, so that most
> probably it enters an infinite loop (a hup signal kills the emacs
> process immediately).

> i obtain this behaviour also when using 'emacs -q', so that i'm quite
> sure that it is not caused by any configuration of mine.

> since i use w3m on a daily basis, and plan to use jde too, this
> problem is really a showstopper for me. i've tried to have a look at
> the source, but i don't know where or what to look for. and of course
> i have no idea of whether jde, w3m-el or emacs is the real culprit.

> i'd really appreciate any help or ideas.

> best regards,
> jao
> -- 
> "Beware of bugs in the above code; I have only proved it correct,
> not tried it." -- Donald Knuth (in a memo to Peter van Emde Boas)