[Date Prev][Date Next][Thread Prev][][Date Index][Thread Index]

Re: `wrong-type-argument arrayp nil` and `w3m-ems`

Thank you so very very very much !!!!  That was it.  I simply turned off the two elc files (you suggested) by renaming them and everything started working correctly.  I am not able to send you the faulty elc files, however, due to size limitations to your mailing list.  Github seems to be just a mirror and there was no place I saw to open an issue and report the bug.  If you could please pass along the bug information to the appropriate team to help out future users, that would be wonderful.

Thanks again -- I'm so happy everything is working !!!!



On May 29, 2013, at 12:27 AM, Katsumi Yamaoka <yamaoka@xxxxxxx> wrote:

> In [emacs-w3m : No.12032] Keith David Bershatsky wrote:
>> I was able to make the installation with Github without errors, but I
>> still have errors when launching Emacs.  Some one suggested that
>> emacs-trunk developer build might have better luck, so I tried that,
>> but that still didn't work.  I've been using Aquamacs developer's
>> build and now Emacs Trunk developer's build on OSX Mountain Lion.
>> Here is the error message posted to stack overflow:
>> http://stackoverflow.com/questions/16804834/any-alternatives-to-emacs-w3m-for-html-decoding-etc
> I'd very much like to track down the cause of the error, only it
> is hard to read a byte-code.  So, could you gather a human readable
> one?  To do that, do the following before trying to run w3m:
> M-x load-library RET w3m.el RET
> M-x load-library RET w3m-ems.el RET
> Note that what you want to load are *.el files, not *.elc files.
> If you still get a `byte-code' in a backtrace, try loading an el
> file that is relevant to a function expressed with a byte-code.
>> It's midnight here in Los Angeles, so I'll have to pick this back up
>> again tomorrow . . . .  Thanks for all of your help -- greatly
>> appreciated !!!!
>> Good night,
>> Keith
> OK.  In Japan I'll still be in a bed when you awake, though. ;-)